Создать тему
Закрыть тему

Compiler AmxModx 1.8.3

Список ответов

Canysin

Canysin

Тех. Поддержка

офлайн

06.05.2018 - 03:24 Сообщение #1

Приветствую!
Данная программа создана для компиляции плагинов(AMXX);
Для того чтобы скомпилировать плагин(AMXX), требуется исходник(SMA).

ВАЖНО:
•Не все плагины могут быть скомпилированы, так как возможны ошибки в исходнике плагина.
•Для компиляции некоторых плагинов может быть потребован директив(INCLUDE-Инклуд), без него компиляция невозможна.
(В папке "include" находятся не все директивы; Если при компиляции потребуется директив, которого нет в папке "include" - Попытайтесь найти его в интернете, вписав его название. Формат директива - ."inc")

-
Сайт с директивами(Include) - КЛИКАБЕЛЬНО!
Путь для установки директивов - "Compiler AmxModx 1.8.3\include"

Как скомпилировать плагин:
Для начала потребуется исходник, на примере будет взят исходник плагина "Lite_Translit.sma";
1. Открываем папку с компилятором "Compiler AmxModx 1.8.3".
2. Перекидываем исходник в саму папку "Compiler AmxModx 1.8.3".
3. После этого нажимаем дважды на "compile.exe".
Компиляция плагина зависит от самого исходника, сколько в нём строк (среднее время ожидания - 1-2 секунды ).
4. После удачного компилирования, файл "Lite_Translit.amxx" будет находится в папке "compiled", где находятся все удачно скомпилированные плагины.
-
Ссылка на скачивание компилятора - КЛИКАБЕЛЬНО!
Распаковать архив на рабочий стол - Папка "Compiler AmxModx 1.8.3"

Сообщение было отредактировано: 06.11.2018 23:05:58

Canysin

Canysin

Тех. Поддержка

офлайн

06.05.2018 - 04:13 Сообщение #2

ПРАВИЛЬНАЯ КОМПИЛЯЦИЯ.


Сообщение было отредактировано: 02.10.2018 05:03:34

Canysin

Canysin

Тех. Поддержка

офлайн

06.05.2018 - 04:13 Сообщение #3

НЕПРАВИЛЬНАЯ КОМПИЛЯЦИЯ.


Сообщение было отредактировано: 02.10.2018 05:03:44

Вход на сайт
 
 
 
 
Авторизоваться
Закрыть
Регистрация
 
 
 
 
 
 
Зарегистрироваться
Закрыть
Восстановление доступа
 
 
Продолжить
Закрыть